中危 Linux Kernel 至 5.2.8 Endpoint Descriptor usb.c null 指针取消引用漏洞

CVE编号

CVE-2019-15098

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-08-16
漏洞描述
Linux内核到5.2.8中的drivers/net/wireless/ath/ath6kl/usb.c通过端点描述符中的不完整地址进行空指针解除引用。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://lore.kernel.org/linux-wireless/20190804002905.11292-1-benquike@gmail.com/T/#u
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp active_iq_unified_manager * From
(including)
9.5
运行在以下环境
应用 netapp data_availability_services - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.04 -
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.87-1
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.210-1
运行在以下环境
系统 linux linux_kernel * Up to
(including)
5.2.9
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.12.14-lp150.12.73.1
运行在以下环境
系统 opensuse_Leap_15.1 linux * Up to
(excluding)
4.12.14-lp151.28.16.1
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 sles_12_SP4 linux * Up to
(excluding)
4.12.14-6.26.1
运行在以下环境
系统 suse_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 suse_12_SP4 linux * Up to
(excluding)
4.12.14-6.26.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.4.0-1058.62
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1058.62
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.4.0-1098.109
运行在以下环境
系统 ubuntu_16.04.7_lts linux * Up to
(excluding)
4.4.0-168.197
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-168.197
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
5.0.0-35.38~18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-69.78
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-69.78
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况