低危 openssl:mingw构建中的不安全路径默认漏洞

CVE编号

CVE-2019-1552

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-31 06:15:00
漏洞描述
OpenSSL是OpenSSL团队的一个开源的能够实现安全套接层(SSLv2/v3)和安全传输层(TLSv1)协议的通用加密库。该产品支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL 1.1.1版本至1.1.1c版本、1.1.0版本至1.1.0k版本和1.0.2版本至1.0.2s版本中存在安全漏洞。攻击者可利用该漏洞绕过安全保护。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.openssl.org/news/secadv/20190730.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 openssl openssl * From
(including)
1.0.2
Up to
(including)
1.0.2s
运行在以下环境
应用 openssl openssl * From
(including)
1.1.0
Up to
(including)
1.1.0k
运行在以下环境
应用 openssl openssl * From
(including)
1.1.1
Up to
(including)
1.1.1c
2
运行在以下环境
系统 debian_9 csync2 * Up to
(excluding)
2.0-8-g175a01c-4+deb9u1
3
运行在以下环境
系统 debian_10 csync2 * Up to
(excluding)
2.0-22-gce67c55-1+deb10u1
4
运行在以下环境
系统 fedora_30 csync2 * Up to
(excluding)
1.0.2o-7.fc30
5
运行在以下环境
系统 fedora_29 csync2 * Up to
(excluding)
1.0.2o-7.fc29
6
运行在以下环境
系统 fedora_31 csync2 * Up to
(excluding)
1.0.2o-8.fc31
阿里云评分
2.8
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-295 证书验证不恰当
阿里云安全产品覆盖情况