低危 python-apt只检查' Version.fetch_binary() '和' Version.fetch_source() '中下载文件的MD5和

CVE编号

CVE-2019-15795

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-03-27
漏洞描述
python-apt只检查1.9.0ubuntu1及更早版本中apt/package.py的' version .fetch_binary() '和' version .fetch_source() '中下载文件的MD5和。这就允许了一种中间人攻击,这种攻击可能用于安装修改过的包,并且已经在1.9.0ubuntu1.2、1.6.5ubuntu0.1、1.1.0~beta1ubuntu0.16.04.7、0.9.3.5ubuntu3+esm2和0.8.3ubuntu7.5版本中得到了修复。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian python-apt 1.8.4 -
运行在以下环境
应用 ubuntu python-apt 0.8.0 -
运行在以下环境
应用 ubuntu python-apt 0.8.1 -
运行在以下环境
应用 ubuntu python-apt 0.8.3 -
运行在以下环境
应用 ubuntu python-apt 0.8.9.1 -
运行在以下环境
应用 ubuntu python-apt 0.9.0 -
运行在以下环境
应用 ubuntu python-apt 0.9.1 -
运行在以下环境
应用 ubuntu python-apt 0.9.3.1 -
运行在以下环境
应用 ubuntu python-apt 0.9.3.2 -
运行在以下环境
应用 ubuntu python-apt 0.9.3.3 -
运行在以下环境
应用 ubuntu python-apt 0.9.3.4 -
运行在以下环境
应用 ubuntu python-apt 0.9.3.5 -
运行在以下环境
应用 ubuntu python-apt 1.0.1 -
运行在以下环境
应用 ubuntu python-apt 1.1.0 -
运行在以下环境
应用 ubuntu python-apt 1.4.0 -
运行在以下环境
应用 ubuntu python-apt 1.6.0 -
运行在以下环境
应用 ubuntu python-apt 1.6.1 -
运行在以下环境
应用 ubuntu python-apt 1.6.2 -
运行在以下环境
应用 ubuntu python-apt 1.6.3 -
运行在以下环境
应用 ubuntu python-apt 1.6.4 -
运行在以下环境
应用 ubuntu python-apt 1.7.0 -
运行在以下环境
应用 ubuntu python-apt 1.8.0 -
运行在以下环境
应用 ubuntu python-apt 1.8.1 -
运行在以下环境
应用 ubuntu python-apt 1.8.2 -
运行在以下环境
应用 ubuntu python-apt 1.8.3 -
运行在以下环境
应用 ubuntu python-apt 1.8.4 -
运行在以下环境
应用 ubuntu python-apt 1.9.0 -
运行在以下环境
系统 debian_10 python-apt * Up to
(excluding)
1.8.4.1
运行在以下环境
系统 debian_8 python-apt * Up to
(excluding)
0.9.3.13
运行在以下环境
系统 debian_9 python-apt * Up to
(excluding)
1.4.1
运行在以下环境
系统 ubuntu_14.04 python-apt * Up to
(excluding)
0.9.3.5ubuntu3+esm2
运行在以下环境
系统 ubuntu_16.04 python-apt * Up to
(excluding)
1.1.0~beta1ubuntu0.16.04.7
运行在以下环境
系统 ubuntu_16.04.7_lts python-apt * Up to
(excluding)
1.1.0~beta1ubuntu0.16.04.7
运行在以下环境
系统 ubuntu_18.04 python-apt * Up to
(excluding)
1.6.5ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts python-apt * Up to
(excluding)
1.6.5ubuntu0.1
阿里云评分
2.6
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-327 使用已被攻破或存在风险的密码学算法
阿里云安全产品覆盖情况