低危 在ptrace_get_debugreg()中backporting错误

CVE编号

CVE-2019-15902

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-04
漏洞描述
在Linux稳定/长期内核4.4.x到4.4.190、4.9.x到4.9.190、4.14.x到4.14.141、4.19.x到4.19.69和5.2.x到5.2.11中发现了一个回溯错误。错误使用上游的“x86/ptrace:修复ptrace_get_debugreg()”commit中可能存在的spectrev1漏洞,重新引入了它想要消除的Spectre漏洞。这是因为backport进程依赖于挑选特定的提交,并且交换了两个(正确排序的)代码行。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.kernel.org
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp service_processor - -
运行在以下环境
系统 amazon linux_AMI linux * Up to
(excluding)
4.14.143-91.122.amzn1
运行在以下环境
系统 amazon_AMI linux * Up to
(excluding)
4.14.143-91.122.amzn1
运行在以下环境
系统 debian debian_linux 10.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 linux * Up to
(excluding)
4.19.67-2+deb10u1
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
4.9.144-3.1~deb8u1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.189-3+deb9u1
运行在以下环境
系统 linux linux_kernel * From
(including)
4.14
Up to
(including)
4.14.141
运行在以下环境
系统 linux linux_kernel * From
(including)
4.19
Up to
(including)
4.19.69
运行在以下环境
系统 linux linux_kernel * From
(including)
4.4
Up to
(including)
4.4.190
运行在以下环境
系统 linux linux_kernel * From
(including)
4.9
Up to
(including)
4.9.190
运行在以下环境
系统 linux linux_kernel * From
(including)
5.2
Up to
(including)
5.2.11
运行在以下环境
系统 netapp baseboard_management_controller_firmware - -
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.12.14-lp150.12.73.1
运行在以下环境
系统 opensuse_Leap_15.1 linux * Up to
(excluding)
4.12.14-lp151.28.16.1
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 sles_12_SP4 linux * Up to
(excluding)
4.12.14-6.26.1
运行在以下环境
系统 suse_12_SP4 linux * Up to
(excluding)
4.12.14-6.26.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.4.0-166.195~14.04.1
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1056.60
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-1047.50
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-166.195
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.15.0-1052.54
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-66.75
运行在以下环境
硬件 netapp baseboard_management_controller - -
阿里云评分
3.4
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况