低危 Oracle Java SE 8u231 JavaFX divide by zero 漏洞

CVE编号

CVE-2019-16168

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-10
漏洞描述
在通过3.29.0的SQLite中,由于缺少对sqlite_stat1 sz字段的验证(也称为“查询计划程序中的零严重除数”),sqlite3.c中的whereLoopAddBtreeIndex可能导致浏览器或其他应用程序崩溃。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp ontap_select_deploy_administration_utility - -
运行在以下环境
应用 sqlite sqlite * From
(including)
3.8.5
Up to
(including)
3.29.0
运行在以下环境
系统 alibaba_cloud_linux_3 lemon * Up to
(excluding)
3.26.0-11.1.al8
运行在以下环境
系统 alma_linux_8 mingw32-bzip2 * Up to
(excluding)
104-2.el8
运行在以下环境
系统 alpine_3.10 sqlite * Up to
(excluding)
3.28.0-r1
运行在以下环境
系统 alpine_3.8 sqlite * Up to
(excluding)
3.25.3-r2
运行在以下环境
系统 alpine_3.9 sqlite * Up to
(excluding)
3.28.0-r1
运行在以下环境
系统 amazon_2 java-11-amazon-corretto * Up to
(excluding)
11.0.6+10-1.amzn2
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.10 -
运行在以下环境
系统 debian_10 sqlite * Up to
(excluding)
3.27.2-3+deb10u1
运行在以下环境
系统 debian_11 sqlite3 * Up to
(excluding)
3.29.0-2
运行在以下环境
系统 debian_12 sqlite3 * Up to
(excluding)
3.29.0-2
运行在以下环境
系统 debian_9 sqlite3 * Up to
(excluding)
3.16.2-5+deb9u2
运行在以下环境
系统 fedoraproject fedora 30 -
运行在以下环境
系统 fedora_29 lemon * Up to
(excluding)
3.26.0-5.fc29
运行在以下环境
系统 fedora_30 lemon * Up to
(excluding)
3.26.0-7.fc30
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse_Leap_15.0 sqlite3 * Up to
(excluding)
3.28.0-lp150.2.9.1
运行在以下环境
系统 opensuse_Leap_15.1 sqlite3 * Up to
(excluding)
3.28.0-lp151.2.3.1
运行在以下环境
系统 oracle_8 lemon * Up to
(excluding)
3.26.0-11.el8
运行在以下环境
系统 redhat_8 lemon * Up to
(excluding)
3.26.0-11.el8
运行在以下环境
系统 suse_12_SP4 sqlite3 * Up to
(excluding)
3.8.10.2-9.12.1
运行在以下环境
系统 suse_12_SP5 sqlite3 * Up to
(excluding)
3.36.0-9.18.1
运行在以下环境
系统 ubuntu_16.04 sqlite3 * Up to
(excluding)
3.11.0-1ubuntu1.3
运行在以下环境
系统 ubuntu_18.04 sqlite3 * Up to
(excluding)
3.22.0-1ubuntu0.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-369 除零错误
阿里云安全产品覆盖情况