低危 Python 安全漏洞

CVE编号

CVE-2019-17514

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-10-13
漏洞描述
如不可重复的cancer-research结果所示,2016年之前的Python 2和3文档中的library/glob.htmll可能会误导有关是否发生排序的信息。注意:本文档的影响跨应用程序域,因此其他地方与安全相关的代码很可能会受到影响。这个问题不是Python的实现错误,也没有报道说NMR研究人员特别依赖library / glob.html。换句话说,因为较早的文档指出“根据Unix Shell使用的规则查找与指定模式匹配的所有路径名”,所以可能会错误地推断出glob.glob也发生在Unix Shell中发生的排序。在较新版本的Willoughby nmr-data_compilation-p2.py和nmr-data_compilation-p3.py中,有一种解决方法,它们直接调用sort()。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python 3.6.0 -
运行在以下环境
应用 python python 3.7.0 -
运行在以下环境
应用 python python 3.8.0 -
运行在以下环境
系统 ubuntu_14.04 python2.7 * Up to
(excluding)
3.4.3-1ubuntu1~14.04.7+esm7
运行在以下环境
系统 ubuntu_14.04_lts python2.7 * Up to
(excluding)
2.7.6-8ubuntu0.6+esm6
运行在以下环境
系统 ubuntu_16.04 python2.7 * Up to
(excluding)
3.5.2-2ubuntu0~16.04.11
运行在以下环境
系统 ubuntu_16.04.7_lts python2.7 * Up to
(excluding)
2.7.12-1ubuntu0~16.04.12
运行在以下环境
系统 ubuntu_16.04_lts python2.7 * Up to
(excluding)
2.7.12-1ubuntu0~16.04.12
运行在以下环境
系统 ubuntu_18.04 python2.7 * Up to
(excluding)
3.7.5-2~18.04.4
运行在以下环境
系统 ubuntu_18.04.5_lts python2.7 * Up to
(excluding)
2.7.17-1~18.04ubuntu1.1
运行在以下环境
系统 ubuntu_18.04_lts python2.7 * Up to
(excluding)
2.7.17-1~18.04ubuntu1.1
运行在以下环境
系统 ubuntu_20.04 python2.7 * Up to
(excluding)
3.8.2-1ubuntu1.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-682 数值计算不正确
NVD-CWE-noinfo
阿里云安全产品覆盖情况