低危 0.60.8之前的GNU Aspell中的libaspell.a具有基于堆栈的缓冲区过度读取

CVE编号

CVE-2019-17544

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-10-14 15:15:00
漏洞描述
libaspell.a在0.60.8之前的GNU Aspell中,通过一个独立的\字符在common/getdata.cpp中的acommon::unescape中有一个基于堆栈的缓冲区过度读取。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/GNUAspell/aspell/commit/80fa26c74279fced8d778351cff19d1d8f44fe4e
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu aspell * Up to
(excluding)
0.60.8
2
运行在以下环境
系统 alpine_3.8 aspell * Up to
(excluding)
0.60.6.1-r13
3
运行在以下环境
系统 alpine_3.9 aspell * Up to
(excluding)
0.60.6.1-r14
4
运行在以下环境
系统 alpine_3.12 aspell * Up to
(excluding)
0.60.8-r0
5
运行在以下环境
系统 alpine_edge aspell * Up to
(excluding)
0.60.8-r0
6
运行在以下环境
系统 alpine_3.11 aspell * Up to
(excluding)
0.60.8-r0
7
运行在以下环境
系统 alpine_3.13 aspell * Up to
(excluding)
0.60.8-r0
8
运行在以下环境
系统 debian_8 aspell * Up to
(excluding)
0.60.7~20110707-1.3+deb8u1
9
运行在以下环境
系统 debian_9 aspell * Up to
(excluding)
0.60.7~20110707-3
10
运行在以下环境
系统 debian_10 aspell * Up to
(excluding)
0.60.7~20110707-6
11
运行在以下环境
系统 alpine_3.7 aspell * Up to
(excluding)
0.60.6.1-r13
12
运行在以下环境
系统 alpine_3.10 aspell * Up to
(excluding)
0.60.6.1-r14
13
运行在以下环境
系统 suse_12_SP4 aspell * Up to
(excluding)
0.60.6.1-18.3.1
14
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况