Cisco IOS XE 输入验证错误漏洞

CVE编号

CVE-2019-1756

利用情况

暂无

补丁情况

N/A

披露时间

2019-03-28
漏洞描述
Cisco IOS XE软件中的漏洞可能允许经过身份验证的远程攻击者使用root权限在受影响设备的底层Linux shell上执行命令。出现此漏洞的原因是受影响的软件不正确地清理了用户提供的输入。具有对受影响设备的有效管理员访问权限的攻击者可以通过在Web UI中提供具有恶意负载的用户名并随后向Web UI中的特定端点发出请求来利用此漏洞。成功的攻击可能允许攻击者以root用户身份运行任意命令,从而完全破坏系统。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190327-iosxe-cmdinject
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 batik * Up to
(excluding)
7.0.76-15.1.al7
运行在以下环境
系统 amazon linux_AMI batik * Up to
(excluding)
3.1-api-8.5.50-1.82.amzn1
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.48-2.amzn2
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
3.1-api-8.5.50-1.82.amzn1
运行在以下环境
系统 cisco ios 11.0(20.3) -
运行在以下环境
系统 cisco ios 16.9(1) -
运行在以下环境
系统 cisco ios_xe 16.7.1 -
运行在以下环境
系统 cisco ios_xe 16.7.1a -
运行在以下环境
系统 cisco ios_xe 16.7.1b -
运行在以下环境
系统 cisco ios_xe 16.7.2 -
运行在以下环境
系统 cisco ios_xe 16.7.3 -
运行在以下环境
系统 cisco ios_xe 16.8.1 -
运行在以下环境
系统 cisco ios_xe 16.8.1a -
运行在以下环境
系统 cisco ios_xe 16.8.1b -
运行在以下环境
系统 cisco ios_xe 16.8.1c -
运行在以下环境
系统 cisco ios_xe 16.8.1d -
运行在以下环境
系统 cisco ios_xe 16.8.1e -
运行在以下环境
系统 cisco ios_xe 16.8.1s -
运行在以下环境
系统 cisco ios_xe 16.8.2 -
运行在以下环境
系统 cisco ios_xe 3.2.0ja -
运行在以下环境
系统 debian_10 batik * Up to
(excluding)
8.0.2+ds-1+deb10u2
运行在以下环境
系统 debian_8 batik * Up to
(excluding)
7.0.56-3+deb8u3
运行在以下环境
系统 debian_9 batik * Up to
(excluding)
7.0.75-1
运行在以下环境
系统 debian_sid batik * Up to
(excluding)
10.0-3
运行在以下环境
系统 fedora_32 batik * Up to
(excluding)
1.13-1.fc32
运行在以下环境
系统 fedora_EPEL_6 batik * Up to
(excluding)
7.0.99-1.el6
运行在以下环境
系统 opensuse_Leap_15.1 batik * Up to
(excluding)
9.0.31-lp151.3.12.1
运行在以下环境
系统 oracle linux_7 batik * Up to
(excluding)
7.0.76-15.el7
运行在以下环境
系统 oracle_7 httpd * Up to
(excluding)
7.0.76-15.el7
运行在以下环境
系统 redhat_7 tomcat * Up to
(excluding)
0:7.0.76-15.el7
运行在以下环境
系统 sles_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 sles_12_SP4 batik * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 sles_12_SP5 batik * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 suse_12_SP4 httpd * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 ubuntu_16.04.7_lts tomcat8 * Up to
(excluding)
8.0.32-1ubuntu1.11
运行在以下环境
系统 ubuntu_16.04_lts tomcat8 * Up to
(excluding)
8.0.32-1ubuntu1.11
CVSS3评分
7.2
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况