低危 Apache Tomcat 至 7.0.98/8.5.49/9.0.29 FORM Authentication 会话固定漏洞

CVE编号

CVE-2019-17563

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-24
漏洞描述
在Apache Tomcat 9.0.0中使用表单身份验证时。M1到9.0.29,8.5.0到8.5.49,7.0.0到7.0.98,攻击者可以执行会话固定攻击的窗口很窄。该窗口被认为太窄,不适合实际利用,但出于谨慎考虑,这个问题一直被视为安全漏洞。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://tomcat.apache.org/security-9.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
7.0.0
Up to
(including)
7.0.98
运行在以下环境
应用 apache tomcat * From
(including)
8.5.0
Up to
(including)
8.5.49
运行在以下环境
应用 apache tomcat * From
(including)
9.0.0
Up to
(including)
9.0.29
运行在以下环境
系统 alibaba_cloud_linux_2.1903 tomcat8 * Up to
(excluding)
7.0.76-15.1.al7
运行在以下环境
系统 amazon linux_AMI tomcat8 * Up to
(excluding)
3.1-api-8.5.50-1.82.amzn1
运行在以下环境
系统 amazon_AMI tomcat8 * Up to
(excluding)
3.1-api-8.5.50-1.82.amzn1
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 tomcat8 * Up to
(excluding)
9.0.31-1~deb10u1
运行在以下环境
系统 debian_8 tomcat8 * Up to
(excluding)
7.0.56-3+deb8u3
运行在以下环境
系统 debian_9 tomcat8 * Up to
(including)
7.0.75-1
运行在以下环境
系统 fedora_EPEL_6 tomcat8 * Up to
(excluding)
7.0.99-1.el6
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse_Leap_15.1 tomcat8 * Up to
(excluding)
9.0.30-lp151.3.6.1
运行在以下环境
系统 oracle linux_7 tomcat8 * Up to
(excluding)
7.0.76-15.el7
运行在以下环境
系统 oracle_7 tomcat8 * Up to
(excluding)
7.0.76-15.el7
运行在以下环境
系统 redhat_7 tomcat * Up to
(excluding)
0:7.0.76-15.el7
运行在以下环境
系统 sles_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 sles_12_SP4 tomcat8 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 sles_12_SP5 tomcat8 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 suse_12_SP4 tomcat8 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12_SP5 tomcat8 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 ubuntu_16.04 tomcat8 * Up to
(excluding)
8.0.32-1ubuntu1.11
运行在以下环境
系统 ubuntu_16.04.7_lts tomcat8 * Up to
(excluding)
8.0.32-1ubuntu1.11
运行在以下环境
系统 ubuntu_16.04_lts tomcat8 * Up to
(excluding)
8.0.32-1ubuntu1.11
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-384 会话固定
阿里云安全产品覆盖情况