低危 Apache Tomcat 至 9.0.30 Header Transfer-Encoding 请求走私漏洞

CVE编号

CVE-2019-17569

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-02-25
漏洞描述
Apache Tomcat 9.0.28至9.0.30、8.5.48至8.5.50和7.0.98至7.0.99中的重构引入了回归。回归的结果是,如果Tomcat位于以特定方式错误处理了无效的Transfer-Encoding头的反向代理后面,则错误地处理了无效的Transfer-Encoding头会导致HTTP请求走私的可能性。这种反向代理被认为是不可能的。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache tomcat * From
(including)
7.0.98
Up to
(including)
7.0.99
运行在以下环境
应用 apache tomcat * From
(including)
8.5.48
Up to
(including)
8.5.50
运行在以下环境
应用 apache tomcat * From
(including)
9.0.28
Up to
(including)
9.0.30
运行在以下环境
系统 amazon linux_AMI tomcat7 * Up to
(excluding)
3.0-api-7.0.100-1.36.amzn1
运行在以下环境
系统 amazon_AMI tomcat7 * Up to
(excluding)
3.0-api-7.0.100-1.36.amzn1
运行在以下环境
系统 debian_10 tomcat7 * Up to
(excluding)
9.0.31-1~deb10u1
运行在以下环境
系统 debian_8 tomcat7 * Up to
(excluding)
7.0.56-3+deb8u3
运行在以下环境
系统 debian_9 tomcat7 * Up to
(including)
7.0.75-1
运行在以下环境
系统 opensuse_Leap_15.1 tomcat7 * Up to
(excluding)
9.0.31-lp151.3.12.1
运行在以下环境
系统 sles_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 sles_12_SP4 tomcat7 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 sles_12_SP5 tomcat7 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12 tomcat * Up to
(excluding)
9.0.31-3.25
运行在以下环境
系统 suse_12_SP4 tomcat7 * Up to
(excluding)
9.0.31-3.25.1
运行在以下环境
系统 suse_12_SP5 tomcat7 * Up to
(excluding)
9.0.31-3.25.1
阿里云评分
3.5
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-444 HTTP请求的解释不一致性(HTTP请求私运)
阿里云安全产品覆盖情况