中危 Cisco Small Business RV320和Cisco Small Business RV325 跨站脚本漏洞

CVE编号

CVE-2019-1827

利用情况

暂无

补丁情况

N/A

披露时间

2019-04-05 05:29:00
漏洞描述
Cisco Small Business RV320和Cisco Small Business RV325都是美国思科(Cisco)公司的一款VPN路由器。
使用1.4.2.22之前版本固件的Cisco Small Business RV320和RV325 Dual Gigabit WAN VPN Routers中的Online Help Web服务存在跨站脚本漏洞,该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190404-rv-xss
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 cisco rv320_firmware * Up to
(excluding)
1.4.2.22
运行在以下环境
系统 cisco rv325_firmware * Up to
(excluding)
1.4.2.22
运行在以下环境
系统 debian_10 bash * Up to
(excluding)
1.8.19-1+deb10u3
运行在以下环境
系统 debian_11 bash * Up to
(excluding)
5.0-7
运行在以下环境
系统 debian_9 bash * Up to
(excluding)
1.7.5-2
运行在以下环境
系统 debian_sid bash * Up to
(excluding)
5.0-7
运行在以下环境
系统 opensuse_Leap_15.0 bash * Up to
(excluding)
2.0.10
运行在以下环境
系统 opensuse_Leap_15.1 bash * Up to
(excluding)
2.0.10
运行在以下环境
系统 oracle linux_8 bash * Up to
(excluding)
1.8.23-3.el8
运行在以下环境
系统 oracle_8 haproxy * Up to
(excluding)
1.8.23-3.el8
运行在以下环境
系统 ubuntu_16.04_lts haproxy * Up to
(excluding)
1.6.3-1ubuntu0.3
运行在以下环境
系统 ubuntu_18.04_lts haproxy * Up to
(excluding)
1.8.8-1ubuntu0.7
运行在以下环境
硬件 cisco rv320 - -
运行在以下环境
硬件 cisco rv325 - -
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况