低危 HTTP请求中的权限升级

CVE编号

CVE-2019-18928

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-15
漏洞描述
Cyrus IMAP2.5.x在2.5.14之前,和3.0.12之前的3.x允许权限升级,因为HTTP请求可能在通过相同连接到达的不相关的先前请求的身份验证上下文中被解释。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.cyrusimap.org/imap/download/release-notes/3.0/x/3.0.12.html
https://www.cyrusimap.org/imap/download/release-notes/2.5/x/2.5.14.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 cyrus imap * From
(including)
2.5.0
Up to
(excluding)
2.5.14
运行在以下环境
应用 cyrus imap * From
(including)
3.0.0
Up to
(excluding)
3.0.12
运行在以下环境
系统 centos_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 debian_10 cyrus-imapd * Up to
(excluding)
3.0.8-6+deb10u3
运行在以下环境
系统 debian_9 cyrus-imapd * Up to
(excluding)
2.5.10-3+deb9u3
运行在以下环境
系统 fedora_30 cyrus-imapd * Up to
(excluding)
3.0.12-1.fc30
运行在以下环境
系统 fedora_31 cyrus-imapd * Up to
(excluding)
3.0.12-1.fc31
运行在以下环境
系统 oracle_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 redhat_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 ubuntu_20.04 cyrus-imapd * Up to
(excluding)
3.0.12-1
运行在以下环境
系统 ubuntu_21.04 cyrus-imapd * Up to
(excluding)
3.0.12-1
运行在以下环境
系统 ubuntu_21.10 cyrus-imapd * Up to
(excluding)
3.0.12-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况