低危 Grafana任意文件读取漏洞

CVE编号

CVE-2019-19499

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-08-29
漏洞描述
Grafana是Grafana实验室的一套提供可视化监控界面的开源监控工具。该工具主要用于监控和分析Graphite、InfluxDB和Prometheus等。 Grafana 6.4.3及之前版本存在任意文件读取漏洞,该漏洞允许攻击者在经过身份认证的条件下,通过修改数据源配置文件利用该漏洞进行攻击。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/grafana/grafana/blob/master/CHANGELOG.md#644-2019-11-06
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 grafana grafana * Up to
(including)
6.4.3
运行在以下环境
系统 centos_8 grafana-prometheus * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-azure-monitor * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-cloudwatch * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-elasticsearch * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-graphite * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-influxdb * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-loki * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-mssql * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-mysql * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-opentsdb * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-postgres * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-prometheus * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 oracle_8 grafana-stackdriver * Up to
(excluding)
6.7.4-3.el8
运行在以下环境
系统 redhat_8 grafana-prometheus * Up to
(excluding)
6.7.4-3.el8
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-200 信息暴露
CWE-89 SQL命令中使用的特殊元素转义处理不恰当(SQL注入)
阿里云安全产品覆盖情况