低危 在Cyrus IMAP 2.5.15之前,3.0.x在3.0.13之前以及3.1.x到3.1.8之间发现了一个问题

CVE编号

CVE-2019-19783

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-17
漏洞描述
在Cyrus IMAP 2.5.15之前,3.0.x在3.0.13之前以及3.1.x到3.1.8之间发现了一个问题。如果允许上载筛选器脚本(3.x)或启用某些非默认筛选器选项(2.x),则在服务上具有邮件帐户的用户可以使用包含fileinto指令的筛选器脚本与管理员创建任何邮箱特权,因为imap/lmtp_sieve.c中的autosieve_createfolder()中的文件夹处理不当。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.cyrusimap.org
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 cyrus imap * From
(including)
2.5.0
Up to
(excluding)
2.5.15
运行在以下环境
应用 cyrus imap * From
(including)
3.0.0
Up to
(excluding)
3.0.13
运行在以下环境
应用 cyrus imap * From
(including)
3.1.0
Up to
(excluding)
3.1.8
运行在以下环境
系统 centos_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 debian_10 cyrus-imapd * Up to
(excluding)
3.0.8-6+deb10u3
运行在以下环境
系统 debian_9 cyrus-imapd * Up to
(excluding)
2.5.10-3+deb9u2
运行在以下环境
系统 fedora_30 cyrus-imapd * Up to
(excluding)
3.0.13-1.fc30
运行在以下环境
系统 fedora_31 cyrus-imapd * Up to
(excluding)
3.0.13-1.fc31
运行在以下环境
系统 oracle_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 redhat_8 cyrus-imapd * Up to
(excluding)
3.0.7-19.el8
运行在以下环境
系统 ubuntu_18.04 cyrus-imapd * Up to
(excluding)
2.5.10-3ubuntu1.1
运行在以下环境
系统 ubuntu_18.04.5_lts cyrus-imapd * Up to
(excluding)
2.5.10-3ubuntu1.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
CWE-269 特权管理不恰当
阿里云安全产品覆盖情况