中危 ATasm 1.06在setparser .c中的parse_expr()函数中有一个基于堆栈的缓冲区溢出

CVE编号

CVE-2019-19786

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-14
漏洞描述
ATasm 1.06通过精心制作的.m65文件在setparser .c中的parse_expr()函数中有一个基于堆栈的缓冲区溢出。

解决建议
目前厂商尚未提供漏洞修补方案,请关注厂商主页及时更新:
https://github.com/linuxha/atasm
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 atasm_project atasm 1.06 -
运行在以下环境
系统 fedora_32 atasm * Up to
(excluding)
1.09-1.fc32
运行在以下环境
系统 fedora_32 atasm-debuginfo * Up to
(excluding)
1.09-1.fc32
运行在以下环境
系统 fedora_33 atasm * Up to
(excluding)
1.09-1.fc33
运行在以下环境
系统 fedora_33 atasm-debuginfo * Up to
(excluding)
1.09-1.fc33
运行在以下环境
系统 fedora_34 atasm * Up to
(excluding)
1.09-1.fc34
运行在以下环境
系统 fedora_34 atasm-debuginfo * Up to
(excluding)
1.09-1.fc34
运行在以下环境
系统 fedora_EPEL_7 atasm * Up to
(excluding)
1.09-1.el7
运行在以下环境
系统 fedora_EPEL_7 atasm-debuginfo * Up to
(excluding)
1.09-1.el7
运行在以下环境
系统 fedora_EPEL_8 atasm * Up to
(excluding)
1.09-1.el8
运行在以下环境
系统 fedora_EPEL_8 atasm-debuginfo * Up to
(excluding)
1.09-1.el8
阿里云评分
6.3
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况