低危 GraphicsMagick 缓冲区错误漏洞

CVE编号

CVE-2019-19951

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-24
漏洞描述
GraphicsMagick是一套简单的图像处理工具。该工具对图像提供尺寸调整、旋转、加亮等功能。
GraphicsMagick 1.4 20190423版本中的coders/miff.c文件的‘ImportRLEPixels’函数存在缓冲区错误漏洞。攻击者可借助特制文件利用该漏洞在系统上执行任意代码。

解决建议
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/bc99af93614d
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick 1.4 -
运行在以下环境
系统 debian_10 graphicsmagick * Up to
(excluding)
1.4~hg15978-1+deb10u1
运行在以下环境
系统 debian_8 graphicsmagick * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u3
运行在以下环境
系统 opensuse_Leap_15.1 graphicsmagick * Up to
(excluding)
3-1.3.29-lp151.4.14.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况