低危 SQLite 安全漏洞

CVE编号

CVE-2019-19959

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-01-04
漏洞描述
SQLite是美国D.Richard Hipp软件开发者的一套基于C语言的开源嵌入式关系数据库管理系统。该系统具有独立性、隔离性、跨平台等特点。
SQLite 3.30.1版本中的ext/misc/zipfile.c文件存在缓冲区错误漏洞,该漏洞源于当文件名包含‘’字符,程序没有正确处理INSERT INTO语句的使用。远程攻击者可借助特制文件名利用该漏洞导致拒绝服务。

解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.sqlite.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 sqlite sqlite 3.30.1 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.10 -
运行在以下环境
系统 centos_8 sqlite3 * Up to
(excluding)
3.26.0-6.el8
运行在以下环境
系统 debian_10 sqlite3 * Up to
(excluding)
3.27.2-3+deb10u1
运行在以下环境
系统 opensuse_Leap_15.2 sqlite3 * Up to
(excluding)
0-3.36.0-lp152.4.3.1
运行在以下环境
系统 opensuse_Leap_15.3 sqlite3 * Up to
(excluding)
3.36.0-3.12.1
运行在以下环境
系统 oracle linux_8 sqlite3 * Up to
(excluding)
3.26.0-6.el8
运行在以下环境
系统 oracle_8 sqlite3 * Up to
(excluding)
3.26.0-6.el8
运行在以下环境
系统 redhat_8 sqlite3 * Up to
(excluding)
3.26.0-6.el8
运行在以下环境
系统 suse_12_SP5 sqlite3 * Up to
(excluding)
0-3.36.0-9.18.1
运行在以下环境
系统 ubuntu_18.04 sqlite3 * Up to
(excluding)
3.22.0-1ubuntu0.3
运行在以下环境
系统 ubuntu_18.04_lts sqlite3 * Up to
(excluding)
3.22.0-1ubuntu0.3
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-Other
阿里云安全产品覆盖情况