低危 GNU LibreDWG decode_R13_R2000越界读取安全漏洞

CVE编号

CVE-2019-20011

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-27
漏洞描述
GNU LibreDWG是一个用C编程的软件库,用于管理DWG计算机文件。GNU LibreDWG 0.92版本,decode.c的decode_R13_R2000中存在安全漏洞。可导致堆缓冲区越界读取。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/LibreDWG/libredwg
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu libredwg 0.9.2 -
运行在以下环境
应用 opensuse backports_sle 15.0 -
运行在以下环境
系统 opensuse_Leap_15.1 libredwg * Up to
(excluding)
0.9.3-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 libredwg-devel * Up to
(excluding)
0.9.3-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 libredwg-tools * Up to
(excluding)
0.9.3-lp151.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 libredwg0 * Up to
(excluding)
0.9.3-lp151.2.3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况