低危 UPX 缓冲区错误漏洞

CVE编号

CVE-2019-20021

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-27
漏洞描述
UPX是一款可移植、可扩展的可执行压缩程序。
UPX 3.95版本中的p_mach.cpp文件的‘canUnpack’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/upx/upx/commit/819c33fee2b2c33b96bef27a13cb20f2589819aa
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.95 -
运行在以下环境
系统 alpine_3.12 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.13 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.14 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.15 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.16 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_edge upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 debian_10 upx * Up to
(including)
3.95-1
运行在以下环境
系统 debian_9 upx * Up to
(including)
3.91-4
运行在以下环境
系统 fedora_30 upx * Up to
(excluding)
3.95-5.fc30
运行在以下环境
系统 fedora_31 upx * Up to
(excluding)
3.95-5.fc31
运行在以下环境
系统 fedora_EPEL_7 upx * Up to
(excluding)
3.95-5.el7
运行在以下环境
系统 fedora_EPEL_8 upx * Up to
(excluding)
3.95-5.el8
运行在以下环境
系统 opensuse_Leap_15.1 upx * Up to
(excluding)
3.96-lp151.3.3.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况