在GrantPermissionsActivity.java的onPermissionGrantResult中,可能存在错误授予的权限

CVE编号

CVE-2019-2005

利用情况

暂无

补丁情况

N/A

披露时间

2019-06-20
漏洞描述
在GrantPermissionsActivity.java的onPermissionGrantResult中,由于缺少权限检查,可能会错误地授予权限。这可能导致锁定设备上的特权本地升级,而无需额外的执行权限。开发需要用户交互。产品:AndroidVersions:Android-8.0 Android-8.1 Android-9Android ID:A-68777217

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alpine_3.12 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.13 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_edge upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 centos_8 upx * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 debian_10 upx * Up to
(excluding)
1.8.2-1+deb10u1
运行在以下环境
系统 debian_11 upx * Up to
(excluding)
0.0~git20200713.b42009b+ds-1
运行在以下环境
系统 debian_8 upx * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 debian_9 upx * Up to
(excluding)
1.5.2-2+deb9u1
运行在以下环境
系统 debian_sid upx * Up to
(excluding)
0.0~git20200713.b42009b+ds-1
运行在以下环境
系统 fedora_30 upx * Up to
(excluding)
3.96-1.fc30
运行在以下环境
系统 fedora_31 upx * Up to
(excluding)
3.96-2.fc31
运行在以下环境
系统 fedora_32 upx * Up to
(excluding)
1.5.18-1.fc32
运行在以下环境
系统 fedora_33 upx * Up to
(excluding)
1.5.18-1.fc33
运行在以下环境
系统 fedora_EPEL_7 upx * Up to
(excluding)
3.96-1.el7
运行在以下环境
系统 fedora_EPEL_8 upx * Up to
(excluding)
3.96-1.el8
运行在以下环境
系统 google android 8.0 -
运行在以下环境
系统 google android 8.1 -
运行在以下环境
系统 google android 9.0 -
运行在以下环境
系统 opensuse_Leap_15.1 upx * Up to
(excluding)
3.96-lp151.3.3.1
运行在以下环境
系统 oracle linux_6 upx * Up to
(excluding)
4.1.12-124.43.4.el6uek
运行在以下环境
系统 oracle linux_7 upx * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_6 upx * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_7 upx * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_8 upx * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1160.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1160.rt56.1131.el7
运行在以下环境
系统 redhat_8 upx * Up to
(excluding)
4.18.0-240.el8
运行在以下环境
系统 sles_12 kernel-azure * Up to
(excluding)
4.12.14-16.7
运行在以下环境
系统 sles_12_SP4 upx * Up to
(excluding)
4.12.14-6.37.1
运行在以下环境
系统 sles_12_SP5 upx * Up to
(excluding)
4.12.14-16.7.1
运行在以下环境
系统 suse_12_SP4 upx * Up to
(excluding)
4.12.14-6.37.1
运行在以下环境
系统 suse_12_SP5 upx * Up to
(excluding)
4.12.14-16.7.1
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1054.58
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-157.185
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-60.67
CVSS3评分
8.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-862 授权机制缺失
阿里云安全产品覆盖情况