低危 UPX 3.95中p_lx_elf.cpp中的PackLinuxElf::elf_hash中发现了一个浮点异常。

CVE编号

CVE-2019-20051

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-12-28
漏洞描述
UPX 3.95中p_lx_elf.cpp中的PackLinuxElf::elf_hash中发现了一个浮点异常。该漏洞会导致应用程序崩溃,从而导致拒绝服务。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/upx/upx
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.95 -
运行在以下环境
系统 debian_10 upx-ucl * Up to
(excluding)
3.95-1
运行在以下环境
系统 debian_9 upx-ucl * Up to
(excluding)
3.91-4
运行在以下环境
系统 fedora_30 upx-ucl * Up to
(excluding)
3.96-1.fc30
运行在以下环境
系统 fedora_31 upx-ucl * Up to
(excluding)
3.96-2.fc31
运行在以下环境
系统 fedora_EPEL_7 upx-ucl * Up to
(excluding)
3.96-1.el7
运行在以下环境
系统 fedora_EPEL_8 upx-ucl * Up to
(excluding)
3.96-1.el8
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-682 数值计算不正确
阿里云安全产品覆盖情况