低危 libbsd 缓冲区错误漏洞

CVE编号

CVE-2019-20367

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-01-09
漏洞描述
libbsd 0.10.0之前版本中的nlist.c文件存在缓冲区错误漏洞。本地攻击者可利用该漏洞获取敏感信息或导致应用程序崩溃。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://gitlab.freedesktop.org/libbsd/libbsd/commit/9d917aad37778a9f4a96ba358415f077f3f36f3b
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freedesktop libbsd * Up to
(excluding)
0.10.0
运行在以下环境
系统 alpine_3.10 libbsd * Up to
(excluding)
0.9.1-r1
运行在以下环境
系统 alpine_3.11 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_3.12 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_3.13 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_3.14 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_3.15 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_3.16 libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 alpine_edge libbsd * Up to
(excluding)
0.10.0-r0
运行在以下环境
系统 debian_10 libbsd * Up to
(excluding)
0.9.1-2+deb10u1
运行在以下环境
系统 debian_9 libbsd * Up to
(excluding)
0.8.3-1+deb9u1
运行在以下环境
系统 opensuse_Leap_15.1 libbsd * Up to
(excluding)
0.8.7-lp151.3.3.1
运行在以下环境
系统 ubuntu_14.04 libbsd * Up to
(excluding)
0.6.0-2ubuntu1+esm1
运行在以下环境
系统 ubuntu_16.04 libbsd * Up to
(excluding)
0.8.2-1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts libbsd * Up to
(excluding)
0.8.2-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04 libbsd * Up to
(excluding)
0.8.7-1ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts libbsd * Up to
(excluding)
0.8.7-1ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况