低危 UCS-2和UCS-4空终止的字符串处理OOB读取

CVE编号

CVE-2019-20433

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-01-28 04:15:00
漏洞描述
libaspell.a在0.60.8之前的GNU Aspell中,如果在应用程序外部将编码设置为ucs-2或ucs-4,则会对以单个“\0”字节结尾的字符串进行缓冲区overread,如ASPELL_CONF环境变量所示。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://aspell.net/buffer-overread-ucs.txt
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu aspell * Up to
(excluding)
0.60.8
2
运行在以下环境
系统 debian_9 aspell * Up to
(excluding)
0.60.7~20110707-3
3
运行在以下环境
系统 debian_10 aspell * Up to
(excluding)
0.60.7~20110707-6+deb10u1
4
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.8.2
5
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.8.2
6
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.8.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况