严重 Android 缓冲区错误漏洞

CVE编号

CVE-2019-2047

利用情况

暂无

补丁情况

N/A

披露时间

2019-05-09 06:29:00
漏洞描述
在ic.cc的UpdateLoadElement中,由于类型混淆,可能存在越界写入。这可能会导致代理自动配置中的远程代码执行,而无需额外的执行权限。利用不需要用户交互。产品:Android版本:Android-7.0 Android-7.1.1 Android-7.1.2 Android-8.0 Android-8.1 Android-9 Android ID:A-117607414

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://source.android.com/security/bulletin/2019-05-01
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 ruamel.yaml * Up to
(excluding)
1.8.8-7.1.al7
运行在以下环境
系统 amazon linux_2 ruamel.yaml * Up to
(excluding)
1.8.8-7.amzn2
运行在以下环境
系统 amazon linux_AMI ruamel.yaml * Up to
(excluding)
1.8.8-7.6.amzn1
运行在以下环境
系统 amazon_2 mod_auth_openidc * Up to
(excluding)
1.8.8-7.amzn2
运行在以下环境
系统 amazon_AMI mod_auth_openidc * Up to
(excluding)
1.8.8-7.6.amzn1
运行在以下环境
系统 centos_8 oraclelinux-release * Up to
(excluding)
2.3.7-4.module+el8.2.0+6919+ac02cfd2.3
运行在以下环境
系统 debian_10 ruamel.yaml * Up to
(excluding)
2.3.10.2-1
运行在以下环境
系统 debian_11 ruamel.yaml * Up to
(excluding)
0.16.12-2
运行在以下环境
系统 debian_8 ruamel.yaml * Up to
(excluding)
1.6.0-1+deb8u3
运行在以下环境
系统 debian_9 ruamel.yaml * Up to
(excluding)
2.1.6-1+deb9u1
运行在以下环境
系统 debian_sid ruamel.yaml * Up to
(excluding)
0.17.16-1
运行在以下环境
系统 fedora_30 ruamel.yaml * Up to
(excluding)
5.3-2.fc30
运行在以下环境
系统 fedora_31 ruamel.yaml * Up to
(excluding)
5.3-2.fc31
运行在以下环境
系统 fedora_32 ruamel.yaml * Up to
(excluding)
2.4.2.1-1.fc32
运行在以下环境
系统 google android 7.0 -
运行在以下环境
系统 google android 7.1.1 -
运行在以下环境
系统 google android 7.1.2 -
运行在以下环境
系统 google android 8.0 -
运行在以下环境
系统 google android 8.1 -
运行在以下环境
系统 google android 9.0 -
运行在以下环境
系统 opensuse_Leap_15.1 ruamel.yaml * Up to
(excluding)
2.3.8-lp151.2.6.1
运行在以下环境
系统 oracle linux_7 ruamel.yaml * Up to
(excluding)
1.8.8-7.el7
运行在以下环境
系统 oracle linux_8 ruamel.yaml * Up to
(excluding)
2.3.7-4.module+el8.2.0+7637+70221d24.3
运行在以下环境
系统 oracle_7 oraclelinux-release * Up to
(excluding)
1.8.8-7.el7
运行在以下环境
系统 oracle_8 oraclelinux-release * Up to
(excluding)
2.3.7-4.module+el8.2.0+7637+70221d24.3
运行在以下环境
系统 redhat_7 mod_auth_openidc * Up to
(excluding)
0:1.8.8-7.el7
运行在以下环境
系统 redhat_8 oraclelinux-release * Up to
(excluding)
2.3.7-4.module+el8.2.0+6919+ac02cfd2.3
运行在以下环境
系统 sles_12 apache2-mod_auth_openidc * Up to
(excluding)
2.4.0-3.11
运行在以下环境
系统 sles_12_SP4 ruamel.yaml * Up to
(excluding)
2.4.0-3.11.1
运行在以下环境
系统 sles_12_SP5 ruamel.yaml * Up to
(excluding)
2.4.0-3.11.1
CVSS3评分
9.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
CWE-843 使用不兼容类型访问资源(类型混淆)
阿里云安全产品覆盖情况