Android Libxaac 缓冲区错误漏洞

CVE编号

CVE-2019-2080

利用情况

暂无

补丁情况

N/A

披露时间

2019-09-28
漏洞描述
Android是美国谷歌(Google)和开放手持设备联盟(简称OHA)的一套以Linux为基础的开源操作系统。
Android 10版本中的libxaac存在缓冲区错误漏洞。攻击者可利用该漏洞执行代码。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://source.android.com/security/bulletin/android-10
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 amazon linux_AMI vim * Up to
(excluding)
8.0.0503-1.47.amzn1
运行在以下环境
系统 debian_10 vim * Up to
(excluding)
3.95-1
运行在以下环境
系统 debian_8 vim * Up to
(excluding)
4.9.144-3.1~deb8u1
运行在以下环境
系统 debian_9 vim * Up to
(excluding)
3.91-4
运行在以下环境
系统 google android 10.0 -
运行在以下环境
系统 opensuse_Leap_15.1 vim * Up to
(excluding)
8.0.1568-lp151.5.6.1
运行在以下环境
系统 oracle linux_7 vim * Up to
(excluding)
4.2.1-5.el7
运行在以下环境
系统 oracle linux_8 vim * Up to
(excluding)
8.0.1763-15.0.1.el8
运行在以下环境
系统 oracle_7 kernel * Up to
(excluding)
4.2.1-5.el7
运行在以下环境
系统 sles_12 gvim * Up to
(excluding)
7.4.326-17.6
运行在以下环境
系统 sles_12 kernel-azure * Up to
(excluding)
4.12.14-16.16
运行在以下环境
系统 sles_12_SP4 vim * Up to
(excluding)
7.4.326-17.6.1
运行在以下环境
系统 sles_12_SP5 vim * Up to
(excluding)
7.4.326-17.6.1
运行在以下环境
系统 suse_12 gvim * Up to
(excluding)
7.4.326-17.6
运行在以下环境
系统 suse_12_SP4 kernel * Up to
(excluding)
4.12.14-6.43.1
运行在以下环境
系统 suse_12_SP5 kernel * Up to
(excluding)
4.12.14-16.16.1
运行在以下环境
系统 ubuntu_14.04_lts linux * Up to
(excluding)
3.11.0-12.19
运行在以下环境
系统 ubuntu_16.04.7_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.2.0-16.19
运行在以下环境
系统 ubuntu_16.04_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_18.04.5_lts linux * Up to
(excluding)
4.15.0-91.92
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-91.92
运行在以下环境
系统 ubuntu_18.04_lts vim * Up to
(excluding)
2:8.0.1453-1ubuntu1.4
CVSS3评分
8.8
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况