低危 3.96之前的UPX中的p_lx_elf.cpp具有整数溢出

CVE编号

CVE-2019-20805

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-06-02
漏洞描述
3.96之前的UPX中的p_lx_elf.cpp在通过PT_DYNAMIC段中的精巧值进行拆包时有整数溢出。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/upx/upx/commit/8be9da8280dfa69d5df4417d4d81bda1cab78010
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx * Up to
(excluding)
3.96
运行在以下环境
系统 debian_10 upx-ucl * Up to
(excluding)
3.95-1
运行在以下环境
系统 debian_9 upx-ucl * Up to
(excluding)
3.91-4
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况