低危 在8.1.0881之前的Vim中,用户可以绕过rvim受限模式并执行任意OS命令

CVE编号

CVE-2019-20807

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-05-29
漏洞描述
在8.1.0881之前的Vim中,用户可以绕过rvim受限模式并通过脚本接口(例如Python,Ruby或Lua)执行任意OS命令。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/vim/vim/releases/tag/v8.1.0881
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 vim vim * Up to
(excluding)
8.1.0881
运行在以下环境
系统 amazon_AMI vim * Up to
(excluding)
8.0.0503-1.47.amzn1
运行在以下环境
系统 centos_8 vim * Up to
(excluding)
8.0.1763-15.el8
运行在以下环境
系统 debian_10 vim * Up to
(excluding)
2:8.1.0875-5+deb10u1
运行在以下环境
系统 debian_9 vim * Up to
(excluding)
2:8.0.0197-4+deb9u4
运行在以下环境
系统 opensuse_Leap_15.1 vim * Up to
(excluding)
8.0.1568-lp151.5.6.1
运行在以下环境
系统 oracle_8 vim * Up to
(excluding)
8.0.1763-15.0.1.el8
运行在以下环境
系统 redhat_8 vim * Up to
(excluding)
8.0.1763-15.el8
运行在以下环境
系统 suse_12 gvim * Up to
(excluding)
7.4.326-17.6
运行在以下环境
系统 suse_12_SP4 vim * Up to
(excluding)
7.4.326-17.6.1
运行在以下环境
系统 suse_12_SP5 vim * Up to
(excluding)
7.4.326-17.6.1
运行在以下环境
系统 ubuntu_14.04 vim * Up to
(excluding)
2:7.4.052-1ubuntu3.1+esm4
运行在以下环境
系统 ubuntu_16.04 vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_16.04.7_lts vim * Up to
(excluding)
2:7.4.1689-3ubuntu1.5
运行在以下环境
系统 ubuntu_18.04 vim * Up to
(excluding)
2:8.0.1453-1ubuntu1.4
运行在以下环境
系统 ubuntu_18.04.5_lts vim * Up to
(excluding)
2:8.0.1453-1ubuntu1.4
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况