中危 gnu aspell 跨界内存写

CVE编号

CVE-2019-25051

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-07-20 15:15:00
漏洞描述
objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called from acommon::StringMap::add and acommon::Config::lookup_list).
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu aspell 0.60.8 -
2
运行在以下环境
系统 alpine_3.11 aspell * Up to
(excluding)
0.60.8-r1
3
运行在以下环境
系统 ubuntu_21.04 aspell * Up to
(excluding)
0.60.8-2ubuntu0.1
4
运行在以下环境
系统 ubuntu_20.04 aspell * Up to
(excluding)
0.60.8-1ubuntu0.1
5
运行在以下环境
系统 ubuntu_16.04 aspell * Up to
(excluding)
0.60.7~20110707-3ubuntu0.1+esm1
6
运行在以下环境
系统 ubuntu_18.04 aspell * Up to
(excluding)
0.60.7~20110707-4ubuntu0.2
7
运行在以下环境
系统 ubuntu_14.04 aspell * Up to
(excluding)
0.60.7~20110707-1ubuntu1+esm2
8
运行在以下环境
系统 alpine_3.12 aspell * Up to
(excluding)
0.60.8-r1
9
运行在以下环境
系统 alpine_edge aspell * Up to
(excluding)
0.60.8-r1
10
运行在以下环境
系统 alpine_3.14 aspell * Up to
(excluding)
0.60.8-r1
11
运行在以下环境
系统 debian_9 aspell * Up to
(excluding)
0.60.7~20110707-3+deb9u1
12
运行在以下环境
系统 debian_11 aspell * Up to
(excluding)
0.60.8-2
13
运行在以下环境
系统 debian_10 aspell * Up to
(excluding)
0.60.7~20110707-6+deb10u1
14
运行在以下环境
系统 alpine_3.13 aspell * Up to
(excluding)
0.60.8-r1
15
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.11.1
16
运行在以下环境
系统 fedora_34 aspell * Up to
(excluding)
0.60.8-7.fc34
17
运行在以下环境
系统 opensuse_Leap_15.3 aspell * Up to
(excluding)
0.60.8-3.3.1
18
运行在以下环境
系统 opensuse_Leap_15.2 aspell * Up to
(excluding)
0.60.8-lp152.2.3.1
19
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.11.1
20
运行在以下环境
系统 opensuse_Leap_15.3 aspell * Up to
(excluding)
0.60.8-3.3.1
21
运行在以下环境
系统 opensuse_Leap_15.2 aspell * Up to
(excluding)
0.60.8-lp152.2.3.1
22
运行在以下环境
系统 suse_12_SP5 aspell * Up to
(excluding)
0.60.6.1-18.11.1
23
运行在以下环境
系统 opensuse_Leap_15.3 aspell * Up to
(excluding)
0.60.8-3.3.1
24
运行在以下环境
系统 opensuse_Leap_15.2 aspell * Up to
(excluding)
0.60.8-lp152.2.3.1
阿里云评分
4.2
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况