低危 apt/apt-get 远程代码执行漏洞

CVE编号

CVE-2019-3462

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-29
漏洞描述
apt/apt-get 进行任意软件的安装、更新等,默认会走 HTTP 而非 HTTPS,HTTP流量劫持手段相对简单,攻击者成功劫持HTTP流量后利用返回包CRLF注入可构造合法的安装包签名,从而获取目标服务器root权限。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://security-tracker.debian.org/tracker/CVE-2019-3462
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 debian advanced_package_tool * Up to
(excluding)
1.2.30
运行在以下环境
应用 debian advanced_package_tool * From
(including)
1.3
Up to
(including)
1.4.8
运行在以下环境
应用 netapp active_iq - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
系统 debian_8 apt * Up to
(excluding)
1.0.9.8.4
运行在以下环境
系统 debian_9 apt * Up to
(excluding)
1.4.9
运行在以下环境
系统 ubuntu_14.04 apt * Up to
(excluding)
1.0.1ubuntu2.19
运行在以下环境
系统 ubuntu_14.04.6_lts apt * Up to
(excluding)
1.0.1ubuntu2.19
运行在以下环境
系统 ubuntu_16.04 apt * Up to
(excluding)
1.2.29ubuntu0.1
运行在以下环境
系统 ubuntu_16.04.7_lts apt * Up to
(excluding)
1.2.29ubuntu0.1
运行在以下环境
系统 ubuntu_18.04 apt * Up to
(excluding)
1.6.6ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts apt * Up to
(excluding)
1.6.6ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 apt * Up to
(excluding)
1.7.0ubuntu0.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况