低危 Ansible 至 2.5.14/2.6.13/2.7.7 Fetch Module 路径遍历漏洞

CVE编号

CVE-2019-3828

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-28 02:29:00
漏洞描述
版本2.5.15,2.6.14,2.7.8之前的Ansible fetch模块具有路径遍历漏洞,该漏洞允许通过不限制绝对路径来复制和覆盖本地ansible控制器主机中指定目标之外的文件。<br>
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://www.ansible.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * From
(including)
2.5.0
Up to
(excluding)
2.5.15
运行在以下环境
应用 redhat ansible * From
(including)
2.6.0
Up to
(excluding)
2.6.14
运行在以下环境
应用 redhat ansible * From
(including)
2.7.0
Up to
(excluding)
2.7.8
2
运行在以下环境
系统 opensuse_Leap_42.3 ansible * Up to
(excluding)
2.8.1-12.1
3
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.8.1-12.1
4
运行在以下环境
系统 opensuse_Leap_15.0 ansible * Up to
(excluding)
2.8.1-12.1
5
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
6
运行在以下环境
系统 alpine_3.8 ansible * Up to
(excluding)
2.5.15-r0
7
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.9.7-r0
8
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.8.11-r0
9
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.9.7-r0
10
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.17-r0
11
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.9.7-r0
12
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.9.7-r0
13
运行在以下环境
系统 fedora_29 ansible * Up to
(excluding)
2.7.8-1.fc29
14
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.7.8-1.el7
15
运行在以下环境
系统 fedora_28 ansible * Up to
(excluding)
2.7.8-1.fc28
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况