低危 XDG_SEAT欺骗允许针对“allow_active”而不是“allow_any”检查操作

CVE编号

CVE-2019-3842

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-10
漏洞描述
在v242-rc4之前的systemd中,发现pam_systemd在使用XDG_SEAT变量之前没有正确地清理环境。在某些特定配置中,攻击者可以设置XDG_SEAT环境变量,该变量允许使用“allow_active”元素而不是“allow_any”来针对polkit策略检查命令。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 systemd_project systemd * Up to
(including)
241
运行在以下环境
应用 systemd_project systemd 242 -
运行在以下环境
系统 centos_8 systemd * Up to
(excluding)
239-45.el8
运行在以下环境
系统 debian_8 systemd * Up to
(excluding)
215-17+deb8u8
运行在以下环境
系统 debian_9 systemd * Up to
(excluding)
232-25+deb9u11
运行在以下环境
系统 fedora_30 systemd * Up to
(excluding)
241-5.git3d835d0.fc30
运行在以下环境
系统 opensuse_Leap_42.3 systemd * Up to
(excluding)
228-71.1
运行在以下环境
系统 oracle_8 systemd * Up to
(excluding)
239-45.0.1.el8
运行在以下环境
系统 redhat_8 systemd * Up to
(excluding)
239-45.el8
运行在以下环境
系统 suse_12 libsystemd0-228 * Up to
(excluding)
150.66
运行在以下环境
系统 suse_12_SP3 systemd * Up to
(excluding)
228-150.66.4
运行在以下环境
系统 suse_12_SP4 systemd * Up to
(excluding)
228-150.66.4
运行在以下环境
系统 ubuntu_14.04 systemd * Up to
(excluding)
204-5ubuntu20.31
运行在以下环境
系统 ubuntu_14.04.6_lts systemd * Up to
(excluding)
204-5ubuntu20.31
运行在以下环境
系统 ubuntu_16.04 systemd * Up to
(excluding)
229-4ubuntu21.21
运行在以下环境
系统 ubuntu_16.04.7_lts systemd * Up to
(excluding)
229-4ubuntu21.21
运行在以下环境
系统 ubuntu_18.04 systemd * Up to
(excluding)
237-3ubuntu10.19
运行在以下环境
系统 ubuntu_18.04.5_lts systemd * Up to
(excluding)
237-3ubuntu10.19
运行在以下环境
系统 ubuntu_18.10 systemd * Up to
(excluding)
239-7ubuntu10.12
阿里云评分
2.3
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-264 权限、特权和访问控制
CWE-285 授权机制不恰当
CWE-863 授权机制不正确
阿里云安全产品覆盖情况