低危 Linux Kernel 'marvell/mwifiex/scan.c'堆溢出漏洞

CVE编号

CVE-2019-3846

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-04
漏洞描述
在连接到恶意无线网络时,mwifiex内核模块中发现了一个漏洞,该漏洞使攻击者可以破坏内存并可能升级特权。

解决建议
https://www.kernel.org/
参考链接
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00039.html
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00040.html
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00048.html
http://packetstormsecurity.com/files/153702/Slackware-Security-Advisory-Slack...
http://packetstormsecurity.com/files/154245/Kernel-Live-Patch-Security-Notice...
http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice...
https://access.redhat.com/errata/RHSA-2019:2703
https://access.redhat.com/errata/RHSA-2019:2741
https://access.redhat.com/errata/RHSA-2019:3055
https://access.redhat.com/errata/RHSA-2019:3076
https://access.redhat.com/errata/RHSA-2019:3089
https://access.redhat.com/errata/RHSA-2020:0174
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3846
https://lists.debian.org/debian-lts-announce/2019/06/msg00010.html
https://lists.debian.org/debian-lts-announce/2019/06/msg00011.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://seclists.org/bugtraq/2019/Jul/33
https://seclists.org/bugtraq/2019/Jun/26
https://seclists.org/oss-sec/2019/q2/133
https://security.netapp.com/advisory/ntap-20190710-0002/
https://usn.ubuntu.com/4093-1/
https://usn.ubuntu.com/4094-1/
https://usn.ubuntu.com/4095-1/
https://usn.ubuntu.com/4095-2/
https://usn.ubuntu.com/4117-1/
https://usn.ubuntu.com/4118-1/
https://www.debian.org/security/2019/dsa-4465
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_unified_manager_for_vmware_vsphere * From
(including)
9.5
运行在以下环境
应用 netapp hci_management_node - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.04 -
运行在以下环境
系统 centos_7 linux * Up to
(excluding)
3.10.0-1062.4.1.el7
运行在以下环境
系统 centos_8 linux * Up to
(excluding)
4.18.0-80.11.1.el8_0
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.168-1+deb9u3
运行在以下环境
系统 fedoraproject fedora 29 -
运行在以下环境
系统 fedoraproject fedora 30 -
运行在以下环境
系统 fedora_29 linux * Up to
(excluding)
5.1.6-200.fc29
运行在以下环境
系统 fedora_30 linux * Up to
(excluding)
5.1.7-300.fc30
运行在以下环境
系统 linux linux_kernel - -
运行在以下环境
系统 netapp a700s_firmware - -
运行在以下环境
系统 netapp cn1610_firmware - -
运行在以下环境
系统 netapp h610s_firmware - -
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse leap 42.3 -
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.12.14-lp150.12.64.1
运行在以下环境
系统 opensuse_Leap_15.1 linux * Up to
(excluding)
4.12.14-lp151.28.7.1
运行在以下环境
系统 opensuse_Leap_42.3 linux * Up to
(excluding)
4.4.180-102.1
运行在以下环境
系统 oracle linux_6 linux * Up to
(excluding)
4.1.12-124.43.4.el6uek
运行在以下环境
系统 oracle linux_7 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle linux_8 linux * Up to
(excluding)
4.18.0-80.11.1.el8_0
运行在以下环境
系统 oracle_6 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_8 linux * Up to
(excluding)
4.18.0-80.11.1.el8_0
运行在以下环境
系统 redhat enterprise_linux 6.0 -
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1062.4.1.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1062.4.1.rt56.1027.el7
运行在以下环境
系统 redhat_7 kpatch-patch-3_10_0-1062_1_1 * Up to
(excluding)
0:1-4.el7
运行在以下环境
系统 redhat_8 linux * Up to
(excluding)
4.18.0-80.11.1.el8_0
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 sles_12_SP3 linux * Up to
(excluding)
4.4.180-4.31.1
运行在以下环境
系统 sles_12_SP4 linux * Up to
(excluding)
4.12.14-6.15.2
运行在以下环境
系统 suse_12_SP3 linux * Up to
(excluding)
4.4.180-4.31.1
运行在以下环境
系统 suse_12_SP4 linux * Up to
(excluding)
4.12.14-6.15.2
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
4.4.0-1054.58
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1054.58
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.4.0-1118.127
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-159.187
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.15.0-1047.49
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-58.64
运行在以下环境
硬件 netapp a700s - -
运行在以下环境
硬件 netapp cn1610 - -
运行在以下环境
硬件 netapp h610s - -
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况