低危 使用特制的SSH数据包进行越界读取

CVE编号

CVE-2019-3861

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-26
漏洞描述
在1.8.1之前的libssh2中发现了超出范围的读取缺陷,该缺陷是通过分析填充长度值大于数据包长度的SSH数据包的方式进行的。危害SSH服务器的远程攻击者可能会导致拒绝服务或读取客户端内存中的数据。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.libssh2.org/CVE-2019-3861.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libssh2 libssh2 * From
(including)
0.15
Up to
(including)
1.8.0
运行在以下环境
应用 netapp ontap_select_deploy_administration_utility - -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 libssh2-debuginfo * Up to
(excluding)
1.8.0-3.1.al7
运行在以下环境
系统 alpine_3.10 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.11 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.12 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.13 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.14 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.15 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.16 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.17 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.18 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_3.9 libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 alpine_edge libssh2 * Up to
(excluding)
1.8.1-r0
运行在以下环境
系统 amazon_2 libssh2 * Up to
(excluding)
1.4.3-12.amzn2.2.1
运行在以下环境
系统 centos_7 libssh2 * Up to
(excluding)
1.8.0-3.el7
运行在以下环境
系统 debian_10 libssh2 * Up to
(excluding)
1.8.0-2.1
运行在以下环境
系统 debian_11 libssh2 * Up to
(excluding)
1.8.0-2.1
运行在以下环境
系统 debian_12 libssh2 * Up to
(excluding)
1.8.0-2.1
运行在以下环境
系统 debian_sid libssh2 * Up to
(excluding)
1.8.0-2.1
运行在以下环境
系统 fedora_28 libssh2-debuginfo * Up to
(excluding)
1.8.1-1.fc28
运行在以下环境
系统 fedora_29 libssh2-debuginfo * Up to
(excluding)
1.8.1-1.fc29
运行在以下环境
系统 fedora_30 libssh2-debuginfo * Up to
(excluding)
1.8.2-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 libssh2 * Up to
(excluding)
1-1.8.0-lp150.3.3.1
运行在以下环境
系统 opensuse_Leap_15.1 libssh2 * Up to
(excluding)
1.9.0-lp151.6.6.1
运行在以下环境
系统 opensuse_Leap_15.2 libssh2 * Up to
(excluding)
1-1.9.0-lp152.8.3.1
运行在以下环境
系统 opensuse_Leap_42.3 libssh2 * Up to
(excluding)
1-1.4.3-19.3.1
运行在以下环境
系统 oracle_7 oraclelinux-release * Up to
(excluding)
1.8.0-3.el7
运行在以下环境
系统 redhat_7 libssh2 * Up to
(excluding)
1.8.0-3.el7
运行在以下环境
系统 suse_11_SP4 libssh2 * Up to
(excluding)
1-1.4.3-17.3.1
运行在以下环境
系统 suse_12 libssh2-1 * Up to
(excluding)
1.4.3-20.3
运行在以下环境
系统 suse_12_SP3 libssh2-1-32bit * Up to
(excluding)
1.4.3-20.3.1
运行在以下环境
系统 suse_12_SP4 libssh2-1-32bit * Up to
(excluding)
1.4.3-20.3.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况