低危 将共享外的注册表文件保存为非特权用户

CVE编号

CVE-2019-3880

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-10
漏洞描述
在samba实现模拟Windows registry service API的 RPC endpoint 的方式中发现了一个漏洞。无特权的攻击者可以利用此漏洞在具有unix权限的任何地方创建新的registry hive file,这可能导致在Samba共享中创建新文件。 4.8.11,4.9.6和4.10.2之前的版本容易受到攻击。

解决建议
目前厂商未提供修复方案,请关注厂商主页:
https://www.samba.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat gluster_storage 3.0 -
运行在以下环境
应用 samba samba * Up to
(excluding)
4.8.11
运行在以下环境
应用 samba samba * From
(including)
4.10.0
Up to
(excluding)
4.10.2
运行在以下环境
应用 samba samba * From
(including)
4.9.0
Up to
(excluding)
4.9.6
运行在以下环境
系统 alibaba_cloud_linux_3 ctdb * Up to
(excluding)
4.13.3-5.al8.1
运行在以下环境
系统 alpine_3.10 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.11 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.12 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.13 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.14 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.15 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.16 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.17 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.18 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.19 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.6 samba * Up to
(excluding)
4.6.16-r1
运行在以下环境
系统 alpine_3.7 samba * Up to
(excluding)
4.7.6-r3
运行在以下环境
系统 alpine_3.8 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 alpine_3.9 samba * Up to
(excluding)
4.8.11-r0
运行在以下环境
系统 amazon_2 samba * Up to
(excluding)
4.9.1-6.amzn2.0.1
运行在以下环境
系统 amazon_AMI samba * Up to
(excluding)
4.9.1-6.46.amzn1
运行在以下环境
系统 centos_7 samba * Up to
(excluding)
4.9.1-6.el7
运行在以下环境
系统 debian_10 samba * Up to
(excluding)
4.9.5+dfsg-3
运行在以下环境
系统 debian_11 samba * Up to
(excluding)
4.9.5+dfsg-3
运行在以下环境
系统 debian_12 samba * Up to
(excluding)
4.9.5+dfsg-3
运行在以下环境
系统 fedora_28 samba-test * Up to
(excluding)
4.8.11-0.fc28
运行在以下环境
系统 fedora_29 samba-test * Up to
(excluding)
4.9.6-0.fc29
运行在以下环境
系统 fedora_30 samba-test * Up to
(excluding)
4.10.2-0.fc30
运行在以下环境
系统 kylinos_aarch64_V10 ctdb * Up to
(excluding)
4.10.16-9.el7_9
运行在以下环境
系统 kylinos_x86_64_V10 ctdb * Up to
(excluding)
4.10.16-9.el7_9
运行在以下环境
系统 opensuse_Leap_15.0 ctdb * Up to
(excluding)
4.7.11
运行在以下环境
系统 opensuse_Leap_42.3 ctdb * Up to
(excluding)
4.6.16
运行在以下环境
系统 oracle_7 ctdb * Up to
(excluding)
4.9.1-6.el7
运行在以下环境
系统 oracle_8 ctdb * Up to
(excluding)
4.10.4-1.el8
运行在以下环境
系统 redhat_7 samba * Up to
(excluding)
4.9.1-6.el7
运行在以下环境
系统 redhat_8 ctdb * Up to
(excluding)
4.10.4-1.el8
运行在以下环境
系统 suse_12_SP3 samba * Up to
(excluding)
4.6.16
运行在以下环境
系统 suse_12_SP4 samba * Up to
(excluding)
4.6.16
运行在以下环境
系统 ubuntu_14.04 samba * Up to
(excluding)
4.3.11+dfsg-0ubuntu0.14.04.20
运行在以下环境
系统 ubuntu_16.04 samba * Up to
(excluding)
4.3.11+dfsg-0ubuntu0.16.04.19
运行在以下环境
系统 ubuntu_18.04 samba * Up to
(excluding)
4.7.6+dfsg~ubuntu-0ubuntu2.9
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-22 对路径名的限制不恰当(路径遍历)
阿里云安全产品覆盖情况