低危 389-ds-base up to 1.4.1.2 Timeout LDAP Request 拒绝服务漏洞

CVE编号

CVE-2019-3883

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-18 03:29:00
漏洞描述
在版本为1.4.1.2的389-ds-base中,请求由 workers threads处理。worker将等待每个套接字最多“ioblocktimeout”秒。但是,此超时仅适用于未加密的请求。使用SSL / TLS的连接在读取期间不考虑此超时,并且可能会挂起更长时间。未经身份验证的攻击者可能会重复创建挂起的LDAP请求以挂起所有 worker,从而导致拒绝服务。
解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://directory.fedoraproject.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 fedoraproject 389_directory_server * Up to
(including)
1.4.1.2
2
运行在以下环境
系统 redhat_8 389-ds-base * Up to
(excluding)
1.4.1.3-7.module+el8.1.0+4150+5b8c2c1f
3
运行在以下环境
系统 centos_8 389-ds-base * Up to
(excluding)
1.4.1.3-7.module+el8.1.0+4150+5b8c2c1f
4
运行在以下环境
系统 amazon_2 389-ds-base * Up to
(excluding)
1.3.8.4-25.1.amzn2.0.1
5
运行在以下环境
系统 amazon_AMI 389-ds-base * Up to
(excluding)
1.3.9.1-12.65.amzn1
6
运行在以下环境
系统 debian_10 389-ds-base * Up to
(excluding)
1.4.0.21-1
7
运行在以下环境
系统 debian_9 389-ds-base * Up to
(excluding)
1.3.5.17-2
8
运行在以下环境
系统 debian_8 389-ds-base * Up to
(excluding)
1.3.3.5-4+deb8u1
9
运行在以下环境
系统 centos_7 389-ds-base * Up to
(excluding)
1.3.8.4-25.1.el7_6
10
运行在以下环境
系统 oracle_7 389-ds-base * Up to
(excluding)
1.3.8.4-25.1.el7_6
11
运行在以下环境
系统 alibaba_cloud_linux_2.1903 389-ds-base * Up to
(excluding)
1.3.8.4-25.1.1.al7
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-772 对已超过有效生命周期的资源丧失索引
阿里云安全产品覆盖情况