低危 泄漏凭证到日志文件UndertowLogger.REQUEST_LOGGER.undertowRequestFailed

CVE编号

CVE-2019-3888

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-13
漏洞描述
在2.0.21之前的Undertow Web服务器中发现了一个漏洞。通过日志文件显示纯文本凭据的信息,因为Connectors.executeRootHandler:402使用UndertowLogger.REQUEST_LOGGER.undertowRequestFailed(t,exchange)将HttpServerExchange对象记录在ERROR级别<br>
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/undertow-io/undertow/pull/736
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat undertow * Up to
(excluding)
2.0.21
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 ubuntu_20.04 undertow * Up to
(excluding)
2.0.23-1
运行在以下环境
系统 ubuntu_21.04 undertow * Up to
(excluding)
2.0.23-1
阿里云评分
3.4
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    DoS
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-532 通过日志文件的信息暴露
阿里云安全产品覆盖情况