低危 在setuid程序中,perf_event_open()和execve() race允许数据泄漏

CVE编号

CVE-2019-3901

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-23
漏洞描述
perf_event_open()中的竞态条件允许本地攻击者泄漏来自setuid程序的敏感数据。没有相关的锁(尤其是cred_guard_mutex)期间举行ptrace_may_access()调用,可以指定目标任务执行execve()系统调用setuid执行之前perf_event_alloc()附加到它,允许攻击者绕过ptrace_may_access()检查和perf_event_exit_task(当前)调用中执行install_exec_creds()在特权execve()调用。这个问题影响4.8之前的内核版本。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_unified_manager_for_vmware_vsphere * From
(including)
9.5
运行在以下环境
应用 netapp hci_management_node - -
运行在以下环境
应用 netapp snapprotect - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
应用 netapp storage_replication_adapter_for_clustered_data_ontap_for_vmware_vsphere * From
(including)
7.2
运行在以下环境
应用 netapp vasa_provider_for_clustered_data_ontap * From
(including)
7.2
运行在以下环境
应用 netapp virtual_storage_console_for_vmware_vsphere * From
(including)
7.2
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 linux linux_kernel * Up to
(excluding)
4.8
运行在以下环境
系统 netapp cn1610_firmware - -
运行在以下环境
系统 oracle linux_7 linux * Up to
(excluding)
3.10.0-1127.el7
运行在以下环境
系统 oracle_6 linux-snapdragon * Up to
(excluding)
4.1.12-124.56.1.el6uek
运行在以下环境
系统 oracle_7 linux-snapdragon * Up to
(excluding)
3.10.0-1127.el7
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1127.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1127.rt56.1093.el7
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1002.2
运行在以下环境
系统 ubuntu_16.04 linux-snapdragon * Up to
(excluding)
4.4.0-1019.22
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-28.47
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.13.0-16.19
运行在以下环境
系统 ubuntu_18.10 linux * Up to
(excluding)
4.15.0-20.21
运行在以下环境
硬件 netapp cn1610 - -
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    容易
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-667 加锁机制不恰当
阿里云安全产品覆盖情况