中危 Rails <= 5.2.1 Accept头任意文件读取漏洞

CVE编号

CVE-2019-5418

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2019-03-28
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Action View(Rails)&lt;5.2.2.1,&lt;5.1.6.2,&lt;5.0.7.2,&lt;4.2.11.1中存在文件内容泄露漏洞,其中特制的接受标头可能导致目标系统文件系统上任意文件的内容泄漏。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://rubyonrails.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
应用 redhat cloudforms 4.7 -
运行在以下环境
应用 redhat software_collections 1.0 -
运行在以下环境
应用 rubyonrails rails * From
(including)
3.0.0
Up to
(excluding)
4.2.11.1
运行在以下环境
应用 rubyonrails rails * From
(including)
5.0.0
Up to
(excluding)
5.0.7.2
运行在以下环境
应用 rubyonrails rails * From
(including)
5.1.0
Up to
(excluding)
5.1.6.2
运行在以下环境
应用 rubyonrails rails * From
(including)
5.2.0
Up to
(excluding)
5.2.2.1
运行在以下环境
系统 debian_8 rails * Up to
(excluding)
2:4.1.8-1+deb8u1
运行在以下环境
系统 debian_9 rails * Up to
(excluding)
2:4.2.7.1-1+deb9u1
运行在以下环境
系统 fedora_30 rails * Up to
(excluding)
5.2.3-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 rails * Up to
(excluding)
5.1.4-lp150.2.3.1
阿里云评分
6.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况