低危 在udhcp组件中越界读取导致信息泄露

CVE编号

CVE-2019-5747

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-10 05:29:00
漏洞描述
通过1.30.0在BusyBox中发现了一个问题。在udhcp组件中读取的超出范围(由DHCP服务器,客户端和/或中继使用)可能允许远程攻击者通过发送精心制作的DHCP消息从堆栈中泄漏敏感信息。这与解码DHCP_SUBNET时保证4字节长度有关。注意:此问题的存在是因为CVE-2018-20679的修复程序不完整。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugs.busybox.net/show_bug.cgi?id=11506
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 busybox busybox * Up to
(including)
1.30.0
运行在以下环境
系统 alpine_3.10 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.11 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.12 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.13 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.14 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.15 busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 alpine_3.9 busybox * Up to
(excluding)
1.29.3-r10
运行在以下环境
系统 alpine_edge busybox * Up to
(excluding)
1.30.1-r2
运行在以下环境
系统 ubuntu_14.04 busybox * Up to
(excluding)
1:1.21.0-1ubuntu1.4
运行在以下环境
系统 ubuntu_16.04 busybox * Up to
(excluding)
1:1.22.0-15ubuntu1.4
运行在以下环境
系统 ubuntu_18.04 busybox * Up to
(excluding)
1:1.27.2-2ubuntu3.2
运行在以下环境
系统 ubuntu_20.04 busybox * Up to
(excluding)
1:1.27.2-2ubuntu5
运行在以下环境
系统 ubuntu_21.04 busybox * Up to
(excluding)
1:1.27.2-2ubuntu5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况