低危 正在丢失的字符编码显示允许欺骗scp客户端输出

CVE编号

CVE-2019-6109

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-01
漏洞描述
在OpenSSH 7.9中发现了一个问题。由于进度显示中缺少字符编码,恶意服务器(或中间人攻击者)可以使用精心设计的对象名来操纵客户端输出,例如,通过使用ANSI控制代码来隐藏正在传输的其他文件。这会影响progressmeter.c中的refresh_progress_meter()。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp element_software - -
运行在以下环境
应用 netapp ontap_select_deploy - -
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 openbsd openssh * Up to
(including)
7.9
运行在以下环境
应用 winscp winscp * Up to
(including)
5.13
运行在以下环境
系统 alpine_3.10 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.11 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.12 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.13 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.14 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.15 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.6 openssh * Up to
(excluding)
7.5_p1-r4
运行在以下环境
系统 alpine_3.7 openssh * Up to
(excluding)
7.5_p1-r10
运行在以下环境
系统 alpine_3.8 openssh * Up to
(excluding)
7.7_p1-r4
运行在以下环境
系统 alpine_3.9 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_edge openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 amazon_2 openssh * Up to
(excluding)
7.4p1-16.amzn2.0.6
运行在以下环境
系统 amazon_AMI openssh * Up to
(excluding)
7.4p1-21.73.amzn1
运行在以下环境
系统 centos_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 debian_8 openssh * Up to
(excluding)
1:6.7p1-5+deb8u6
运行在以下环境
系统 debian_9 openssh * Up to
(excluding)
1:7.4p1-10+deb9u5
运行在以下环境
系统 fedora_30 openssh * Up to
(excluding)
8.0p1-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 openssh * Up to
(excluding)
7.6p1-lp150.8.15.2
运行在以下环境
系统 opensuse_Leap_42.3 openssh * Up to
(excluding)
7.2p2-35.1
运行在以下环境
系统 oracle_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 redhat_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 suse_11_SP4 openssh * Up to
(excluding)
36.12.1
运行在以下环境
系统 suse_12_SP3 openssh * Up to
(excluding)
74.35.1
运行在以下环境
系统 suse_12_SP4 openssh * Up to
(excluding)
74.35.1
运行在以下环境
系统 ubuntu_14.04 openssh * Up to
(excluding)
1:6.6p1-2ubuntu2.12
运行在以下环境
系统 ubuntu_16.04 openssh * Up to
(excluding)
1:7.2p2-4ubuntu2.7
运行在以下环境
系统 ubuntu_18.04 openssh * Up to
(excluding)
1:7.6p1-4ubuntu0.2
运行在以下环境
系统 ubuntu_20.04 openssh * Up to
(excluding)
1:7.9p1-6
运行在以下环境
系统 ubuntu_21.04 openssh * Up to
(excluding)
1:7.9p1-6
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-116 对输出编码和转义不恰当
阿里云安全产品覆盖情况