低危 cairo-arc.c中_cairo_arc_in_direction中的断言问题

CVE编号

CVE-2019-6461

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-17
漏洞描述
在cairo 1.16.0中发现了一个问题。文件cairo-arc.c中的函数_cairo_arc_in_direction存在断言问题。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 cairographics cairo 1.16.0 -
运行在以下环境
系统 alpine_3.12 cairo * Up to
(excluding)
1.16.0-r4
运行在以下环境
系统 alpine_3.13 cairo * Up to
(excluding)
1.16.0-r3
运行在以下环境
系统 alpine_3.14 cairo * Up to
(excluding)
1.16.0-r4
运行在以下环境
系统 alpine_3.15 cairo * Up to
(excluding)
1.16.0-r4
运行在以下环境
系统 alpine_edge cairo * Up to
(excluding)
1.17.4-r1
运行在以下环境
系统 debian_10 cairo * Up to
(including)
1.16.0-4+deb10u1
运行在以下环境
系统 debian_11 cairo * Up to
(including)
1.16.0-5
运行在以下环境
系统 debian_12 cairo * Up to
(including)
1.16.0-5
运行在以下环境
系统 debian_9 cairo * Up to
(including)
1.14.8-1
运行在以下环境
系统 debian_sid cairo * Up to
(including)
1.16.0-5
运行在以下环境
系统 ubuntu_14.04.6_lts cairo * Up to
(excluding)
2019-04-23
运行在以下环境
系统 ubuntu_16.04.7_lts cairo * Up to
(excluding)
2019-04-23
运行在以下环境
系统 ubuntu_18.04.5_lts cairo * Up to
(excluding)
2019-04-23
运行在以下环境
系统 ubuntu_18.10 cairo * Up to
(excluding)
2019-04-23
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-617 可达断言
阿里云安全产品覆盖情况