低危 gnupg.GPG中的输入验证不正确。

CVE编号

CVE-2019-6690

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-22
漏洞描述
python-gnupg 0.4.3允许上下文相关的攻击者欺骗gnupg解密其他非预期的密文。要执行攻击,必须由对手控制gnupg的密码,并信任密文。与影响affect功能组件的“CWE-20:不正确的输入验证”问题相关。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python python-gnupg 0.4.3 -
运行在以下环境
应用 suse backports - -
运行在以下环境
系统 debian_8 python-gnupg * Up to
(excluding)
0.3.6-1+deb8u1
运行在以下环境
系统 debian_9 python-gnupg * Up to
(excluding)
0.3.9-1+deb9u1
运行在以下环境
系统 fedora_28 python-gnupg * Up to
(excluding)
0.4.4-1.fc28
运行在以下环境
系统 fedora_29 python-gnupg * Up to
(excluding)
0.4.4-1.fc29
运行在以下环境
系统 fedora_30 python-gnupg * Up to
(excluding)
0.4.4-1.fc30
运行在以下环境
系统 fedora_31 python-gnupg * Up to
(excluding)
0.4.6-1.fc31
运行在以下环境
系统 fedora_32 python-gnupg * Up to
(excluding)
0.4.6-1.fc32
运行在以下环境
系统 fedora_EPEL_6 python-gnupg * Up to
(excluding)
0.4.6-1.el6
运行在以下环境
系统 fedora_EPEL_7 python-gnupg * Up to
(excluding)
0.4.4-1.el7
运行在以下环境
系统 fedora_EPEL_8 python-gnupg * Up to
(excluding)
0.4.6-1.el8
运行在以下环境
系统 opensuse_Leap_15.0 python-gnupg * Up to
(excluding)
0.4.4-lp150.2.6.1
运行在以下环境
系统 ubuntu_18.04 python-gnupg * Up to
(excluding)
0.4.1-1ubuntu1.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts python-gnupg * Up to
(excluding)
0.4.1-1ubuntu1.18.04.1
运行在以下环境
系统 ubuntu_18.10 python-gnupg * Up to
(excluding)
0.4.1-1ubuntu1.18.10.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况