低危 在gd_gif_out.c,gd_jpeg.c和gd_wbmp.c中的gdImage * Ptr中double free

CVE编号

CVE-2019-6978

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-28
漏洞描述
 GD Graphics Library(又名LibGD)2.2.5在gd_gif_out.c,gd_jpeg.c和gd_wbmp.c中的gdImage * Ptr()函数中具有double free 。注意:PHP不受影响。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd 2.2.5 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 gd * Up to
(excluding)
0.2.8.4-44.1.al7
运行在以下环境
系统 alpine_3.10 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.11 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.12 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.13 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.14 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.15 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.16 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.6 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.7 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.8 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_3.9 gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 alpine_edge gd * Up to
(excluding)
2.2.5-r2
运行在以下环境
系统 amazon_2 gd * Up to
(excluding)
0.2.8.4-44.amzn2.0.1
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
0.2.8.4-41.13.amzn1
运行在以下环境
系统 centos_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 debian_9 gd * Up to
(excluding)
2.2.4-2+deb9u4
运行在以下环境
系统 fedora_28 gd * Up to
(excluding)
0.2.12-1.fc28
运行在以下环境
系统 fedora_29 gd * Up to
(excluding)
2.2.5-8.fc29
运行在以下环境
系统 fedora_30 gd * Up to
(excluding)
2.2.5-9.fc30
运行在以下环境
系统 fedora_31 gd * Up to
(excluding)
2.2.5-10.fc31
运行在以下环境
系统 fedora_32 gd * Up to
(excluding)
2.3.0-1.fc32
运行在以下环境
系统 opensuse_Leap_15.0 gd * Up to
(excluding)
2.2.5-lp150.8.1
运行在以下环境
系统 opensuse_Leap_42.3 gd * Up to
(excluding)
2.1.0-30.1
运行在以下环境
系统 oracle_7 gd * Up to
(excluding)
0.2.8.4-44.el7
运行在以下环境
系统 oracle_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 redhat_7 libwmf * Up to
(excluding)
0:0.2.8.4-44.el7
运行在以下环境
系统 redhat_8 gd * Up to
(excluding)
2.2.5-7.el8
运行在以下环境
系统 suse_11_SP4 gd * Up to
(excluding)
5.3.17-112.53.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-24.12
运行在以下环境
系统 suse_12_SP3 gd * Up to
(excluding)
2.1.0-24.12.1
运行在以下环境
系统 suse_12_SP4 gd * Up to
(excluding)
2.1.0-24.12.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.11
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.11
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.11
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.11
运行在以下环境
系统 ubuntu_18.04 gd * Up to
(excluding)
2.2.5-4ubuntu0.3
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.3
运行在以下环境
系统 ubuntu_18.10 libgd2 * Up to
(excluding)
2.2.5-4ubuntu1.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-415 双重释放
阿里云安全产品覆盖情况