低危 未初始化的堆栈内容泄漏给guest

CVE编号

CVE-2019-7222

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-03-22
漏洞描述
Linux kernel through 4.20.的KVM实现存在信息泄漏。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://www.kernel.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp active_iq_performance_analytics_services - -
运行在以下环境
应用 netapp element_software_management_node - -
运行在以下环境
系统 amazon linux_2 linux * Up to
(excluding)
4.14.101-91.76.amzn2
运行在以下环境
系统 amazon linux_AMI linux * Up to
(excluding)
4.14.101-75.76.amzn1
运行在以下环境
系统 amazon_2 linux * Up to
(excluding)
4.14.101-91.76.amzn2
运行在以下环境
系统 amazon_AMI linux * Up to
(excluding)
4.14.101-75.76.amzn1
运行在以下环境
系统 canonical ubuntu_linux 12.04 -
运行在以下环境
系统 canonical ubuntu_linux 14.04 -
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.10 -
运行在以下环境
系统 centos_8 linux * Up to
(excluding)
4.18.0-147.el8
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian_8 linux * Up to
(excluding)
3.16.57-1
运行在以下环境
系统 debian_9 linux * Up to
(excluding)
4.9.161-1
运行在以下环境
系统 fedoraproject fedora 28 -
运行在以下环境
系统 fedoraproject fedora 29 -
运行在以下环境
系统 fedora_28 linux * Up to
(excluding)
4.20.8-100.fc28
运行在以下环境
系统 fedora_29 linux * Up to
(excluding)
4.20.8-200.fc29
运行在以下环境
系统 linux linux_kernel * Up to
(including)
4.20.5
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse_Leap_15.0 linux * Up to
(excluding)
4.12.14-lp150.12.48.1
运行在以下环境
系统 opensuse_Leap_42.3 linux * Up to
(excluding)
4.4.175-89.1
运行在以下环境
系统 oracle linux_6 linux * Up to
(excluding)
4.1.12-124.43.4.el6uek
运行在以下环境
系统 oracle linux_7 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle linux_8 linux * Up to
(excluding)
4.18.0-147.el8
运行在以下环境
系统 oracle_6 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_7 linux * Up to
(excluding)
4.1.12-124.43.4.el7uek
运行在以下环境
系统 oracle_8 linux * Up to
(excluding)
4.18.0-147.el8
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-1062.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-1062.rt56.1022.el7
运行在以下环境
系统 redhat_8 linux * Up to
(excluding)
4.18.0-147.el8
运行在以下环境
系统 sles_11_SP4 linux * Up to
(excluding)
3.0.101-108.87.1
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-120
运行在以下环境
系统 sles_12_SP3 linux * Up to
(excluding)
4.4.176-4.25.1
运行在以下环境
系统 sles_12_SP4 linux * Up to
(excluding)
4.12.14-6.9.1
运行在以下环境
系统 suse_11_SP4 linux * Up to
(excluding)
3.0.101-108.87.1
运行在以下环境
系统 suse_12_SP3 linux * Up to
(excluding)
4.4.176-4.25.1
运行在以下环境
系统 suse_12_SP4 linux * Up to
(excluding)
4.12.14-6.9.1
运行在以下环境
系统 ubuntu_14.04 linux * Up to
(excluding)
3.13.0-168.218
运行在以下环境
系统 ubuntu_14.04_lts linux * Up to
(excluding)
3.13.0-168.218
运行在以下环境
系统 ubuntu_16.04 linux * Up to
(excluding)
4.15.0-1010.12~16.04.1
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-145.171
运行在以下环境
系统 ubuntu_18.04 linux * Up to
(excluding)
4.15.0-1010.12
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-47.50
运行在以下环境
系统 ubuntu_18.10 linux * Up to
(excluding)
4.18.0-17.18
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况