低危 ImageMagick 至 7.0.8-24 coders/pdf.c WritePDFImage 资源管理漏洞

CVE编号

CVE-2019-7397

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-05
漏洞描述
在7.0.8-25之前的ImageMagick中,coders / pdf.c上的readPDFImage中存在多个内存泄漏。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * Up to
(including)
1.3.31
运行在以下环境
应用 imagemagick imagemagick * Up to
(excluding)
7.0.8-25
运行在以下环境
系统 redhat_7 inkscape * Up to
(excluding)
0:0.92.2-3.el7
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-71.108
运行在以下环境
系统 ubuntu_16.04.7_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.14
运行在以下环境
系统 ubuntu_16.04_lts imagemagick * Up to
(excluding)
8:6.8.9.9-7ubuntu5.14
运行在以下环境
系统 ubuntu_18.04.5_lts imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu6.7
运行在以下环境
系统 ubuntu_18.04_lts imagemagick * Up to
(excluding)
8:6.9.7.4+dfsg-16ubuntu6.7
运行在以下环境
系统 ubuntu_18.10 imagemagick * Up to
(excluding)
8:6.9.10.8+dfsg-1ubuntu2.2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-401 在移除最后引用时对内存的释放不恰当(内存泄露)
阿里云安全产品覆盖情况