低危 KDE KAuth 输入验证错误漏洞

CVE编号

CVE-2019-7443

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-05-08
漏洞描述
KDE KAuth 5.55之前的版本允许将任意类型的参数通过DBusHelperProxy.cpp. 某些类型可能会导致崩溃,并使用动态加载的插件触发对任意图像的解码。换句话说,KAuth无意中导致此插件代码以root用户身份运行,这会增加任何可能利用插件漏洞进行攻击的严重性。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://mail.kde.org/pipermail/kde-announce/2019-February/000011.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 kde kauth * Up to
(excluding)
5.55.0
运行在以下环境
应用 opensuse backports - -
运行在以下环境
系统 debian_10 kde4libs * Up to
(including)
4.14.38-3
运行在以下环境
系统 debian_9 kde4libs * Up to
(excluding)
5.28.0-2+deb9u1
运行在以下环境
系统 fedora_28 kde4libs * Up to
(excluding)
5.54.0-2.fc28
运行在以下环境
系统 fedora_29 kde4libs * Up to
(excluding)
5.54.0-2.fc29
运行在以下环境
系统 fedora_EPEL_7 kde4libs * Up to
(excluding)
5.52.0-2.el7
运行在以下环境
系统 opensuse_Leap_15.0 kde4libs * Up to
(excluding)
5.32.0-6.2
运行在以下环境
系统 opensuse_Leap_42.3 kde4libs * Up to
(excluding)
5.32.0-6.2
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况