低危 advancecomp up to 2.0 png.c adv_png_unfilter_8 拒绝服务漏洞

CVE编号

CVE-2019-8383

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-17
漏洞描述
AdvanceCOMP是一款跨平台的数据压缩命令行工具。该产品能够优化压缩文件,减小压缩文件大小。
AdvanceCOMP 2.1之前版本中的png.c文件的‘adv_png_unfilter_8’函数存在缓冲区错误漏洞。存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/amadvance/advancecomp
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 advancemame advancecomp * Up to
(excluding)
2.1
运行在以下环境
系统 alibaba_cloud_linux_2.1903 mercurial * Up to
(excluding)
1.15-21.1.al7
运行在以下环境
系统 amazon_2 mercurial * Up to
(excluding)
2.6.2-10.amzn2
运行在以下环境
系统 debian_9 mercurial * Up to
(excluding)
1.20-1+deb9u1
运行在以下环境
系统 fedora_30 mercurial * Up to
(excluding)
2.1-11.fc30
运行在以下环境
系统 oracle_7 mercurial * Up to
(excluding)
1.15-21.el7
运行在以下环境
系统 redhat_7 advancecomp * Up to
(excluding)
0:1.15-21.el7
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况