中危 bluez bluez 对数据真实性的验证不充分

CVE编号

CVE-2019-8921

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-11-29
漏洞描述
BlueZ是一款使用C语言编写的蓝牙协议堆栈,它主要用于提供对核心蓝牙层和协议的支持。

Bluetoothd in BlueZ 5.48及之前版本存在安全漏洞,攻击者可以通过制作恶意CSTATE,诱使服务器返回比缓冲区实际保存的字节更多的字节,从而导致任意堆数据泄漏。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://ssd-disclosure.com/ssd-advisory-linux-bluez-information-leak-and-heap-overflow/。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bluez bluez * Up to
(including)
5.48
运行在以下环境
系统 debian_10 bluez * Up to
(including)
5.50-1.2~deb10u2
运行在以下环境
系统 debian_9 bluez * Up to
(excluding)
5.43-2+deb9u5
运行在以下环境
系统 ubuntu_18.04 bluez * Up to
(excluding)
5.48-0ubuntu3.6
阿里云评分
5.4
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-345 对数据真实性的验证不充分
阿里云安全产品覆盖情况