中危 BlueZ 缓冲区错误漏洞

CVE编号

CVE-2019-8922

利用情况

暂无

补丁情况

官方补丁

披露时间

2021-11-29
漏洞描述
BlueZ是一款使用C语言编写的蓝牙协议堆栈,它主要用于提供对核心蓝牙层和协议的支持。

BlueZ 5.48及之前版本中的Bluetoothd存在缓冲区错误漏洞,该漏洞源于程序在接收数据时没有任何大小检查,如果一个请求的响应大到足以溢出预分配的缓冲区,就会导致简单的堆溢出。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://ssd-disclosure.com/ssd-advisory-linux-bluez-information-leak-and-heap-overflow/。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bluez bluez * Up to
(including)
5.48
运行在以下环境
系统 debian_10 bluez * Up to
(excluding)
5.50-1.2~deb10u2
运行在以下环境
系统 debian_9 bluez * Up to
(excluding)
5.43-2+deb9u5
阿里云评分
6.2
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况