低危 PHP 至 5.6.39/7.1.25/7.2.13/7.3.0 Regular Expression regcomp.c 越界读取漏洞

CVE编号

CVE-2019-9023

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-23
漏洞描述
在6.0之前的PHP中发现了一个问题,7.1.26之前的7.x,7.2.14之前的7.2.x和7.3.1之前的7.3.x。当提供无效的多字节数据时,mbstring正则表达式函数中存在许多基于堆的缓冲区溢出读取实例。这些发生在ext / mbstring / oniguruma / regcomp.c,ext / mbstring / oniguruma / regexec.c,ext / mbstring / oniguruma / regparse.c,ext / mbstring / oniguruma / enc / unicode.c和ext / mbstring / oniguruma / src / utf32_be.c当多字节正则表达式模式包含无效的多字节序列时。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 php php * Up to
(excluding)
5.6.40
运行在以下环境
应用 php php * From
(including)
7.0.0
Up to
(excluding)
7.1.26
运行在以下环境
应用 php php * From
(including)
7.2.0
Up to
(excluding)
7.2.14
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.1
运行在以下环境
系统 alpine_3.10 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.11 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.12 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.13 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.14 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.15 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_3.8 php5 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.9 php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 alpine_edge php5 * Up to
(excluding)
7.2.14-r0
运行在以下环境
系统 centos_8 php5 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 debian_8 php5 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 debian_9 php5 * Up to
(excluding)
7.0.33-0+deb9u2
运行在以下环境
系统 opensuse_Leap_15.0 php5 * Up to
(excluding)
7.2.5-lp150.2.19.1
运行在以下环境
系统 opensuse_Leap_15.1 php5 * Up to
(excluding)
7.2.5-lp151.6.3.1
运行在以下环境
系统 opensuse_Leap_42.3 php5 * Up to
(excluding)
7.0.7-58.1
运行在以下环境
系统 oracle_8 php5 * Up to
(excluding)
7.2.24-1.module+el8.2.0+5510+6771133c
运行在以下环境
系统 redhat_8 php5 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 suse_11_SP4 php5 * Up to
(excluding)
5.3.17-112.58.1
运行在以下环境
系统 ubuntu_14.04 php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.27
运行在以下环境
系统 ubuntu_16.04 php5 * Up to
(excluding)
7.0.33-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_18.04 php5 * Up to
(excluding)
7.2.15-0ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况